Jump to content

Underligheter med färger i PPro 1.5


kalvfond
 Share

Recommended Posts

Sitter med efterbearbetningen av filmen som jag frågat om här ett par gånger tidigare. Har fått så bra hjälp, så jag hoppas att någon kan hjälpa mig nu också.

 

Problem nummer 1 har att göra med mina textskyltar som visar namn på de medverkade o.s.v. Jag har gjort en skylt i Photoshop, med alphakanal som jag tagit in i Premiere och lagt på ett eget spår. Eftersom jag ville animera skyltens "ingång" och "utgång" och inte var helt nöjd med "frame blendningen" i Premiere har jag gjort den separat i After Effects och tagit in som en AVI med alphakanal, och lagt denna precis innan och efter själva PSD-bilden i Premiere. Ovanpå har jag lagt texter gjorda i Premiere, som jag animerat med samma hastighet som skylten. (se bild 1).

 

Problemet här är att varje gång skylten kommer in, så blir bilden bakom textskylten (d.v.s. där skylten är genomskinlig) lite mörkare. När skylten åkt ut återgår bilden till normal igen. Mycket förbryllande. Vet inte om det kan bero på att vitnivån i skylten är för hög eller något annat.

 

Vet inte om det har med saken att göra, men när jag klickar den gula lilla varningsikonen längst ned till höger ("Events") får jag upp meddelandet "The file ... is created thorugh Photoshop CS. Imported still may not match the original appearance" (för just den bilden).

 

Skum sak nummer två har med effekter och färgnivåer att göra. Varje gång jag lägger på en effekt, vilken som helst, dras färgnivåerna ner, ungefär som om man lagt på en "broadcast safe" eller liknande. Detta händer oavsett vilken effekt (blur, noise, transform...) jag lägger på, och oavsett om effekten verkligen är inställd på att göra något med bilden.

 

Tydligast syns det i vectorscope, se:

Bild 2 - Ingen effekt på klippet

Bild 3 - "Transform" på klippet, utan att ha gjort några ändringar i värdena.

 

Hoppas att någon an hjälpa mig trots mitt extremt långa inlägg...

 

Tack på förhand!

 

/Staffan

bild1.jpg

bild2.jpg

bild3.jpg

Link to comment
Share on other sites

[citat=kalvfond]Sitter med efterbearbetningen av filmen som jag frågat om här ett par gånger tidigare. Har fått så bra hjälp, så jag hoppas att någon kan hjälpa mig nu också.

 

Problem nummer 1 har att göra med mina textskyltar som visar namn på de medverkade o.s.v. Jag har gjort en skylt i Photoshop, med alphakanal som jag tagit in i Premiere och lagt på ett eget spår. Eftersom jag ville animera skyltens "ingång" och "utgång" och inte var helt nöjd med "frame blendningen" i Premiere har jag gjort den separat i After Effects och tagit in som en AVI med alphakanal, och lagt denna precis innan och efter själva PSD-bilden i Premiere. Ovanpå har jag lagt texter gjorda i Premiere, som jag animerat med samma hastighet som skylten. (se bild 1).

 

Problemet här är att varje gång skylten kommer in, så blir bilden bakom textskylten (d.v.s. där skylten är genomskinlig) lite mörkare. När skylten åkt ut återgår bilden till normal igen. Mycket förbryllande. Vet inte om det kan bero på att vitnivån i skylten är för hög eller något annat.

 

Vet inte om det har med saken att göra, men när jag klickar den gula lilla varningsikonen längst ned till höger ("Events") får jag upp meddelandet "The file ... is created thorugh Photoshop CS. Imported still may not match the original appearance" (för just den bilden).[/citat]

Efterssom du har AE så är mitt förslag att göra alla för- och eftertexter i AE istället. Hur du än gör, se till att den fil gjord i Photoshop har samma dimensioner och samma PAR* som ditt project i PPro har, framförallt allt att filen/filerna från Photoshop's PAR stämmer överens med ditt projectets PAR. Att blanda PAR i samma project brukar ofta ge lite skumma problem.

 

PAR står för Pixel Aspect Ratio.

 

Markera valfri fil i Project Window och läs vad som står till höger om den lilla tumnageln uppe till vänster i Project Window. Det står ungefär: 720x576 (1.067)

 

Dina Project Settings i PPro hittar du genom att gå till Project > Project Settings > General

 

När det gäller styrka på färger, mm, mm, i titlar, läs här!

 

 

[citat=kalvfond]Skum sak nummer två har med effekter och färgnivåer att göra. Varje gång jag lägger på en effekt, vilken som helst, dras färgnivåerna ner, ungefär som om man lagt på en "broadcast safe" eller liknande. Detta händer oavsett vilken effekt (blur, noise, transform...) jag lägger på, och oavsett om effekten verkligen är inställd på att göra något med bilden.[/citat]

- Var kommer den bild/film du lägger effekterna på?

- Vilket format har filmen, .avi, .mov, .mpg, mm, mm?

- Är filmen fångad i PPro 1.5?

- Stämmer ditt projects Project Settings överens med din film och bilder?

Link to comment
Share on other sites

Du är minsann både grymt hjälpsam och snabb Rogge!

 

Jo, jag funderade till en början på att göra alla textskyltar i AE istället. Problemet är dock att det inte primärt är för- och eftertexter, utan skyltar som ska ligga ovanpå videoklippen. Och eftersom jag har inte någon möjlighet att exportera hela filmen "lossless" till AE (en timmes video blir ganska stor okomprimerad) hade jag ändå fått göra skyltarna i AE med alphakanal och "composit:a" i Premiere.

 

Problemet är också att det är så jag har gjort med själva in- och utåkningen av skylten. Gjorde amineringen i AE, exporterade som okomprimerad AVI med RGB+Alpha (premultiplied), men ändå blir det konstigt när jag lägger den ovanpå klippet i Premiere.

 

Mitt projekt och mina klipp i Premiere är DV-AVI. "Fångade" i premiere från en DV-kamera. PAR är 1.067 (720x576), samma sak med klippet från AE och med PSD-filen.

 

Creative Cow-artikeln är dunder. Men tyvärr är det just när jag försöker applicera den som det går galet. Oavsett vilka levelsfilter eller så jag lägger på klippen verkar det som resultatet blir samma.

 

Börjar bli lite desperat (snart deadline), så jag tänker kanske inte helt klart...

 

Slutresultatet ska i alla fall hamna på DVD (Mpeg2 således), så jag vill ogärna komprimera om till DV i något steg.

Link to comment
Share on other sites

Update:

Har nu testat även med Quicktime Animering från AE (med alpha). Händer samma sak i Premiere...

 

Det verkar alltså som om färgvärdena justeras ner så fort det inte bara ligger ett obearbetat klipp på timelinen. Så fort ett klipp med alphakanal eller en effekt läggs på, skalar Premiere ned värdena.

 

Gäller förresten 16-235 i alla kanaler som gränsvärden även för DVD, eller har det bara med analog video och TV-sändning att göra?

Link to comment
Share on other sites

[citat=kalvfond]Gjorde amineringen i AE, exporterade som okomprimerad AVI med RGB+Alpha (premultiplied), men ändå blir det konstigt när jag lägger den ovanpå klippet i Premiere.[/citat]

Det här är ett långskott men som är värt att pröva:

 

- Öppna det project du håller på med i AE.

- Öppna den Composition du håller på med och tryck Ctrl+Shift+B

- I rutan Background Color ser du till att välja svart, dvs R=0 G=0 B=0

- Tryck OK

- Gå sedan till Composition > Add to Render Queue

- Under Render Settings väljer du DV Settings

- Kolla att Field Order i DV Settings stämmer överrens med PPro's

- Under Output Module väljer du Custom och under Format väljer du sedan Quick Time Movie

- Under Channels väljer du RGB+Alpha

- Klicka på Format Options och se till att Animering är vald som Komprimeringstyp

- Namnge filen och exportera

 

I PPro, importera filen och lägg den på din Timeline

- Lägg på filtret Remove Matte på filen du exporterade från AE

- Gå till Effect Controls Window

- På effekten Remove Matte, ändra Matte Type från White till Black

 

Med Remove Matte blir texten du exporterade från AE "starkare" och tydligare.

 

Jag tycker att titlar renderade som QuickTime ser bättre ut än avi. Prova och se om det gör någon skillnad. Det är som sagt ett långskott.

 

Testa på en Composition och upprepa om det blir bättre. Background Color måste ändras i varje Composition. Förmodligen är den redan inställd på svart, men att kolla skadar inte.

 

[citat=kalvfond]Mitt projekt och mina klipp i Premiere är DV-AVI. "Fångade" i premiere från en DV-kamera. PAR är 1.067 (720x576), samma sak med klippet från AE och med PSD-filen.[/citat]

Toppen! Har filerna från AE och Photoshop samma dimensioner, dvs 720x576?

 

[citat=kalvfond]Creative Cow-artikeln är dunder. Men tyvärr är det just när jag försöker applicera den som det går galet. Oavsett vilka levelsfilter eller så jag lägger på klippen verkar det som resultatet blir samma.[/citat]

Kanske fungerar det bättre om du exportrar titlen som QuickTime istället för avi.

Link to comment
Share on other sites

Testade att göra som du sa, men tyvärr ingen lycka nu heller.

 

Börjar fundera på om skylten hade fungerat bättre om den inte var vit. Å andra sidan har jag nu testat med en variant som håller sig inom 16-235, men det blir samma resultat. (Det är alltså endast skyltbakgrunden jag tar ifrån AE/PSD, texten lägger jag på i Premiere.)

 

Det finns ingen väl dold inställning i Premiere som ställer in hur den ska bearbeta de olika videospåren?

 

Har förresten nyss inhandlat uppgraderingen till PPro 2.0, men jag vet inte om jag vågar installera det just nu. Om något skulle gå fel under installationen kan produktionen vara "kokt". Annars kanske det är en väg att försöka med? Det sägs ju att färgkorrigeringen är bättre i 2.0.

Link to comment
Share on other sites

[citat=kalvfond]Börjar fundera på om skylten hade fungerat bättre om den inte var vit. Å andra sidan har jag nu testat med en variant som håller sig inom 16-235, men det blir samma resultat. (Det är alltså endast skyltbakgrunden jag tar ifrån AE/PSD, texten lägger jag på i Premiere.)

 

Det finns ingen väl dold inställning i Premiere som ställer in hur den ska bearbeta de olika videospåren?

 

Har förresten nyss inhandlat uppgraderingen till PPro 2.0, men jag vet inte om jag vågar installera det just nu. Om något skulle gå fel under installationen kan produktionen vara "kokt". Annars kanske det är en väg att försöka med? Det sägs ju att färgkorrigeringen är bättre i 2.0.[/citat]

Är bakgrunden enbart vit? I sådant fall kan du ju testa att använda dig av en vit Color Matte i PPro istället för en .PSD-fil. (File > New > Color Matte)

 

Nej, det finns ingen dold inställning för videospåren. Det enda jag kan tänka mig är att Opacity för något av spåren är neddragen. Men det skulle ju inte ge dom resultat du får tycker jag.

 

Min rekommedation är att avsluta det project du håller på med i PPro 1.5 innan du tar in det i PPro 2.0. Du kan dock installera 2.0 utan att den "stör" PPro 1.5. Båda versionerna är fristående från varandra, även uppgraderingar.

 

Nu har jag inte så mycket mer att ge tyvärr. Det är svårt att få en bra helhetsbild när man inte ser hur allt ser ut eller skall se ut.

Link to comment
Share on other sites

Effekten som ligger på är ett blur på 0.3 för att få texten att bli lite lugnare (tips från CCow-artikeln). Testade precis att ta bort effekten, men samma sak händer ändå.

 

Efter att ha studerat det ännu noggrannare verkar det som om bilden blir mörkare i takt med att textskylten åker in. (Textskylten består av ett blurrigt tidningsurklipp som texten sedan läggs på. Se bild). Det får mig att fundera på om det på något sätt är själva vitheten i skylten som gör att bilden påverkas, som om vitnivåerna sänks i videoklippet bakom för att den totala bilden bilden "sammanlagt" ska få samma luminans. Det låter i och för sig helt galet...

 

Några nya uppslag?

bild4.jpg

Link to comment
Share on other sites

[citat=kalvfond]Efter att ha studerat det ännu noggrannare verkar det som om bilden blir mörkare i takt med att textskylten åker in.[/citat]

Efterssom videon är mörk och bilden väldigt ljus så verkar det vara ögat som luras efterssom kontrasterna mellan ljust och mörkt blir stor.

 

Efterssom videon är väldigt mörk hade jag dragit ner ljuset på tidningsurklippet för att jämna ut skillnaden.

Link to comment
Share on other sites

Jag misstänkte också det först, men efter att ha täckt över nedre delen av min TV med en jumper (man tager vad man haver..!) märkte jag att bilden fortfarande blev ljusare. Har också zoomat väldigt långt in i monitorfönstret i Premiere och sett färgändringen i övre delen av bilden.

 

Men jag tror ditt råd var helt rätt. Har under kvällen fixat in nya filer från PS och AE med sänkta nivåer (16-235) på skylten. Den skumma effekten försvinner inte, men den blir mindre märkbar i alla fall.

 

Det känns som det är duger nu i alla fall (även om det alltid är frustrerande att inte veta vad som orsakar problemet).

 

Stort tack för hjälpen igen Rogge! (Med en mindre knapp deadline hade jag garanterat skrivit in dig i eftertexterna.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...